Форумы » Корзина

Why can't I have the same subnet on WAN and LAN?

    • 5 сообщения
    13 июня 2018 г., 23:31:11 PDT

    Hello,

    I've mostly used combination modem/routers in the past so I hadn't really come up against this till now. I have an ADSL modem which serves DHCP, but only to one device. It also doesn't have a configurable IP. I plugged my router into it (connected to the WAN port, of course), but when I do that, I can't use the same subnet on the LAN as on the WAN. (The modem serves 192.168.1.x, so I have to use something else, e.g. 192.168.0.x.) What I don't understand is why those can't be the same. Aren't they separate networks? Doesn't the router's NAT take care of stuff like that? Is this just an arbitrary limitation of this router, or is there some reason it must be this way? Doesn't that create a problem in the way things are modularized? For example, when I was first configuring my router, I had the modem disconnected, and I was configuring it on 192.168.1.x. As soon as I plugged in the modem, it changed my LAN subnet to 10.0.0.x. This leads to the situation in which, if I switch out the modem, and it decides to serve some subnet supposedly "in conflict" with my LAN, my whole LAN is screwed up because it's dependent on some modem which isn't even on the LAN. Likewise, it makes for a restriction in the way I can configure my LAN, based on some silly modem that isn't on the LAN.

    Please help

    I didn't find the right solution from the internet.

    References:
    https://arstechnica.com/civis/viewtopic.php?t=1141632
    Infographic Video Production Service

    Thank you